Calling Services Interruption

Incident Report for VOXO

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 14:40 CDT

Monitoring

Services are now fully operational. We are continuing to monitor critical systems.
Posted Sep 18, 2025 - 11:35 CDT

Update

Outbound calling is now operational. We are continuing to investigate all other components.
Posted Sep 18, 2025 - 11:12 CDT

Investigating

We are currently investigating this issue.
Posted Sep 18, 2025 - 11:10 CDT
This incident affected: Inbound Calling, Outbound Calling, Desktop App, Mobile App, and Contact Center.