This incident has been resolved. Please contact support for any issues.
Posted Apr 17, 2026 - 10:46 CDT
Update
We are continuing to monitor for any further issues.
Posted Apr 17, 2026 - 10:05 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 09:32 CDT
Investigating
We're currently aware of a DNS certificate issue affecting some VOXO services. Our team is actively working on a fix, and we'll keep you updated as we make progress. Thank you for your patience!
Posted Apr 17, 2026 - 09:22 CDT
This incident affected: Inbound Calling, Outbound Calling, Desktop App, Mobile App, Meetings, Messaging, and API.