Admin Portal Account Settings

Incident Report for VOXO

Resolved

We have implemented a fix to resolve the issue and restore performance. Account settings around billing will be temporarily unavailable until the third-party service provider is operational again.
Posted Sep 01, 2026 - 16:33 CDT

Update

We have narrowed down the degraded request to our attempt to pull billing detail along the account settings path. We are planning to implement an override to restore performance while the third party resolves the issue.
Posted Sep 01, 2026 - 16:02 CDT

Identified

We have identified the cause linked to a third party provider along the settings route path.
Posted Sep 01, 2026 - 15:46 CDT

Investigating

The account selector and account settings function in the admin portal are experiencing issues. Our team is investigating the issue.
Posted Sep 01, 2026 - 15:44 CDT