Network Degradation

Incident Report for VOXO

Resolved

The DNS issue has been resolved and services are restored. Please contact support if you are continuing to experience issues.
Posted Mar 30, 2026 - 11:54 CDT

Update

We are continuing to investigate this issue.
Posted Mar 30, 2026 - 11:40 CDT

Update

We are continuing to investigate this issue.
Posted Mar 30, 2026 - 11:36 CDT

Investigating

We are experiencing an issue with services causing network disruption. We are monitoring the provider and will provide updates accordingly.
Posted Mar 30, 2026 - 09:58 CDT
This incident affected: AI Agent and Pharmacy Dashboard.