Intermittent Calling Interruptions

Incident Report for VOXO

Resolved

Services have been restored.
Posted Feb 20, 2026 - 18:19 CST

Identified

We have identified some issues causing service degradation. The team is working on a solution.
Posted Feb 20, 2026 - 18:06 CST

Investigating

We are investigating an issue with degraded service in inbound and outbound calling features.
Posted Feb 20, 2026 - 18:02 CST
This incident affected: Inbound Calling and Outbound Calling.