WIndows click to call still sucks

Incident Report for VOXO

Resolved

got it done
Posted Aug 14, 2026 - 17:06 CDT

Monitoring

missed another small concerned caused by the same failed release.
Posted Aug 14, 2026 - 16:55 CDT

Investigating

this thing is still ugly.
Posted Aug 14, 2026 - 16:54 CDT