Infrastructure Issues

Incident Report for VOXO

Resolved

All services have been restored.
Posted Feb 19, 2026 - 18:17 CST

Identified

We have identified the cause. Affected services are actively being restored. The impact was identified to firmly affect traffic to our central deployment regions. No other traffic regions were determined to be impacted.
Posted Feb 19, 2026 - 18:13 CST

Investigating

Degraded telecom functionality related to core infrastructure. The team is restoring service and investigating the cause.
Posted Feb 19, 2026 - 18:08 CST
This incident affected: Inbound Calling and Outbound Calling.