That last click to call release is raggoly

Incident Report for VOXO

Resolved

There was a rendering issue and another issue we can't fix which is customers hating the product.
Posted Aug 14, 2026 - 16:44 CDT

Monitoring

Issue has been resolved and we are watching closely.
Posted Aug 14, 2026 - 16:40 CDT

Investigating

something wasn't right about that click to call thing
Posted Aug 14, 2026 - 16:19 CDT